Chercher les doublons dans une liste

Voici deux petites astuces pour identifier vos doublons en quelques clics: la première méthode avec les mises en forme conditionnelles et la seconde en utilisant la fonction NB.SI

Les données

Nous prendrons comme exemple le tableau ci-dessous. Il est court. De cette façon, vous pourrez vous entraîner facilement à reproduire les deux méthodes.

Doublons_01

Méthode 1: Mise en forme conditionnelle

Commencez par sélectionner votre plage de cellules à analyser:

Doublons_02

Ensuite, allez dans le Ruban: Accueil > Mise en forme conditionnelle > Règles de mise en surbrillance des cellules > Valeurs en double.

Doublons_03

Vous aurez ensuite le choix:

  1. Choisir de mettre en surbrillance les valeurs uniques ou celles en double
  2. Choisir le couleur de surbrillance.

Doublons_04

Et voici le résultat:

Doublons_05

 

Méthode 2: Avec la fonction Nb.Si

Positionnez-vous sur la première ligne (en face du premier prénom) et tapez la formule suivant:

Doublons_07

Cette fonction permet de compter le nombre de valeurs dans une plage.

=NB.SI(Plage;Valeur_recherchée)

On pourrait aussi l’écrire ainsi:

=NB.SI($A$2:$A$8;A2)

Ensuite, il suffit de dupliquer la formule jusqu’en bas.

Et voici le résultat obtenu:

Doublons_08

Nous voyons bien que Jérémy et Olivier apparaissent deux fois.

 

Lister uniquement les valeurs en doubles

A présent, nous allons trier les prénoms afin de voir les doublons les uns à côté des autres. Vous pouvez faire la même chose avec la méthode de mise en forme conditionnelle.

Sélectionnez la colonne des prénoms puis allez dans le ruban. L’objectif est de trier les prénoms de façon à avoir les doublons qui se suivent.

Ruban: Données > Trier et filtrer > A-Z

Doublons_09

Ensuite, vous allez filtrer pour ne laisser que les doublons dans la colonne.

Sélectionnez la petite flèche à droite du titre “Qte”, puis Filtres numériques et Supérieur à …

Doublons_10

Une fenêtre s’ouvre. Tapez 1 pour afficher toutes les cellules supérieures à 1 (donc les doublons).

Doublons_11

 

Et voici le résultat final. Nous avons uniquement les valeurs en double et les prénoms se suivent, ce qui est plus simple pour l’analyse.

Doublons_12

 

Conclusion

Pour choisir la méthode, il faut avoir en tête plusieurs éléments.

  1. Si voos prénoms sont sur plusieurs colonnes, préférez la mise en forme conditionnelle
  2. Si l’analyse porte sur plusieurs colonnes (par exemple, identifier les doublons sur Nom et Prénom), créez une troisième colonne qui sera la concaténation des deux premières et faites un NB.SI sur cette nouvelle colonne.
  3. Si le nombre de données est très important, préférez NB.SI qui sera plus rapide que les mises en forme conditionnelles qui consomment beaucoup de ressources.

Et si vous souhaitez les supprimer, allez dans le ruban: Données > Outils de données > Supprimer les doublons.

Vous pouvez dès à présent rechercher vos doublons !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *